summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2021-02-18 11:42:46 +0100
committerDaniel Stenberg <daniel@haxx.se>2021-02-18 23:06:47 +0100
commite06fa7462ac258cf6096a0c909310bf23cf7c1eb (patch)
tree632e1f709b6b32db1b6335d8866c0604359c3c5c /configure.ac
parent692faeab9f07c23feddc4814e16a138a30cbab06 (diff)
downloadcurl-e06fa7462ac258cf6096a0c909310bf23cf7c1eb.tar.gz
gnutls: assume nettle crypto support
nettle has been the default crypto library with GnuTLS since 2010. By dropping support for the previous libcrypto, we simplify code. Closes #6625
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac17
1 files changed, 3 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index cf4b5278f..496c18859 100755
--- a/configure.ac
+++ b/configure.ac
@@ -2228,26 +2228,15 @@ if test "$GNUTLS_ENABLED" = "1"; then
USE_GNUTLS_NETTLE=
# First check if we can detect either crypto library via transitive linking
AC_CHECK_LIB(gnutls, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
- if test "$USE_GNUTLS_NETTLE" = ""; then
- AC_CHECK_LIB(gnutls, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
- fi
+
# If not, try linking directly to both of them to see if they are available
if test "$USE_GNUTLS_NETTLE" = ""; then
AC_CHECK_LIB(nettle, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
fi
if test "$USE_GNUTLS_NETTLE" = ""; then
- AC_CHECK_LIB(gcrypt, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
- fi
- if test "$USE_GNUTLS_NETTLE" = ""; then
- AC_MSG_ERROR([GnuTLS found, but neither gcrypt nor nettle found])
- fi
- if test "$USE_GNUTLS_NETTLE" = "1"; then
- AC_DEFINE(USE_GNUTLS_NETTLE, 1, [if GnuTLS uses nettle as crypto backend])
- AC_SUBST(USE_GNUTLS_NETTLE, [1])
- LIBS="-lnettle $LIBS"
- else
- LIBS="-lgcrypt $LIBS"
+ AC_MSG_ERROR([GnuTLS found, but nettle was not found])
fi
+ LIBS="-lnettle $LIBS"
fi
dnl ---