summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-08-31 09:45:09 +0200
committerDaniel Stenberg <daniel@haxx.se>2020-08-31 09:45:09 +0200
commite37e4468688d8f6b9038a0d7085f8c0b2695d112 (patch)
tree50a23e0cfd3a46f332226fe354091d38bfc11b46 /configure.ac
parentede125b7b7ca8fc5a1fe3d7c1aee6bff2ea0bf24 (diff)
downloadcurl-e37e4468688d8f6b9038a0d7085f8c0b2695d112.tar.gz
mqtt: enable by default
No longer considered experimental. Closes #5858
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b063070d5..433a5c22b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -645,11 +645,10 @@ AC_HELP_STRING([--disable-mqtt],[Disable MQTT support]),
[ case "$enableval" in
no)
AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_MQTT, 1, [to disable MQTT])
+ AC_SUBST(CURL_DISABLE_MQTT, [1])
;;
*) AC_MSG_RESULT(yes)
- experimental="$experimental MQTT"
- AC_DEFINE(CURL_ENABLE_MQTT, 1, [to enable MQTT])
- AC_SUBST(CURL_ENABLE_MQTT, [1])
;;
esac ],
AC_MSG_RESULT(no)
@@ -5082,7 +5081,7 @@ fi
if test "x$CURL_DISABLE_GOPHER" != "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS GOPHER"
fi
-if test "x$CURL_ENABLE_MQTT" = "x1"; then
+if test "x$CURL_DISABLE_MQTT" != "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS MQTT"
fi
if test "x$CURL_DISABLE_POP3" != "x1"; then