summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-10-25 23:08:54 +0100
committerDaniel Stenberg <daniel@haxx.se>2020-10-25 23:08:54 +0100
commit96450a1a33ec22cb54b20dbac08ebdf14648582f (patch)
treec3beaaf86442d1934d74a7902e53d29edb4a9a48 /configure.ac
parente2bcdf557b16962af51a34ce493c4375e24895a7 (diff)
downloadcurl-96450a1a33ec22cb54b20dbac08ebdf14648582f.tar.gz
alt-svc: enable by default
Remove CURLALTSVC_IMMEDIATELY, which was never implemented/supported. alt-svc support in curl is no longer considered experimental Closes #5868
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d4ccc268a..b7a7d2daa 100755
--- a/configure.ac
+++ b/configure.ac
@@ -176,9 +176,12 @@ curl_verbose_msg="enabled (--disable-verbose)"
curl_rtmp_msg="no (--with-librtmp)"
curl_mtlnk_msg="no (--with-libmetalink)"
curl_psl_msg="no (--with-libpsl)"
-
+ curl_altsvc_msg="enabled";
ssl_backends=
+
+enable_altsvc="yes"
+
dnl
dnl Save some initial values the user might have provided
dnl
@@ -396,6 +399,10 @@ AC_HELP_STRING([--disable-http],[Disable HTTP support]),
AC_SUBST(CURL_DISABLE_HTTP, [1])
AC_DEFINE(CURL_DISABLE_RTSP, 1, [to disable RTSP])
AC_SUBST(CURL_DISABLE_RTSP, [1])
+ dnl toggle off alt-svc too when HTTP is disabled
+ AC_DEFINE(CURL_DISABLE_ALTSVC, 1, [disable alt-svc])
+ curl_altsvc_msg="no";
+ enable_altsvc="no"
;;
*) AC_MSG_RESULT(yes)
;;
@@ -4864,7 +4871,6 @@ AC_HELP_STRING([--disable-get-easy-options],[Disable curl_easy_options]),
dnl ************************************************************
dnl switch on/off alt-svc
dnl
-curl_altsvc_msg="no (--enable-alt-svc)";
AC_MSG_CHECKING([whether to support alt-svc])
AC_ARG_ENABLE(alt-svc,
AC_HELP_STRING([--enable-alt-svc],[Enable alt-svc support])
@@ -4872,20 +4878,16 @@ AC_HELP_STRING([--disable-alt-svc],[Disable alt-svc support]),
[ case "$enableval" in
no)
AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_ALTSVC, 1, [disable alt-svc])
+ curl_altsvc_msg="no";
+ enable_altsvc="no"
;;
*) AC_MSG_RESULT(yes)
- curl_altsvc_msg="enabled";
- enable_altsvc="yes"
;;
esac ],
AC_MSG_RESULT(no)
)
-if test "$enable_altsvc" = "yes"; then
- AC_DEFINE(USE_ALTSVC, 1, [to enable alt-svc])
- experimental="$experimental alt-svc"
-fi
-
dnl *************************************************************
dnl check whether ECH support, if desired, is actually available
dnl