summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2015-01-22 16:34:18 +0100
committerDaniel Stenberg <daniel@haxx.se>2015-01-22 16:39:01 +0100
commiteb748f159ab9cd426da065d7c1f1a2b3423854b7 (patch)
tree9d0da4f859df384994c4c65d7aff6cb51b6d0534 /configure.ac
parentd6c4695dcd3b2eb73594b9d2891c585fcbaf7f6a (diff)
downloadcurl-eb748f159ab9cd426da065d7c1f1a2b3423854b7.tar.gz
BoringSSL: detected by configure, switches off NTLM
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 04727acbf..2cfe7dd75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1579,7 +1579,8 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
])
dnl these can only exist if openssl exists
- dnl yassl doesn't have SSL_get_shutdown
+ dnl Cyassl doesn't have SSL_get_shutdown
+ dnl BoringSSL doesn't have DES_set_odd_parity
AC_CHECK_FUNCS( RAND_status \
RAND_screen \
@@ -1587,7 +1588,8 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
ENGINE_cleanup \
CRYPTO_cleanup_all_ex_data \
SSL_get_shutdown \
- SSLv2_client_method )
+ SSLv2_client_method \
+ DES_set_odd_parity )
dnl Make an attempt to detect if this is actually yassl's headers and
dnl OpenSSL emulation layer. We still leave everything else believing
@@ -1612,6 +1614,13 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
],[
AC_MSG_RESULT([no])
])
+ AC_MSG_CHECKING([for BoringSSL])
+ if test "x$ac_cv_func_des_set_odd_parity" != "xyes"; then
+ curl_ssl_msg="enabled (BoringSSL)"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
fi
if test "$OPENSSL_ENABLED" = "1"; then