summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-04-15 08:45:35 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-04-15 08:45:35 +0000
commitc2fcdf3a02f271a9a080cb2335ff64965d0939fb (patch)
tree46e9fb2421f9c53f977d71ff72df45b9f9beb7a6 /configure.ac
parent2056a538b99d2fe93c7f7a849f558fde71f42bd2 (diff)
downloadcurl-c2fcdf3a02f271a9a080cb2335ff64965d0939fb.tar.gz
if libgnutls-config isn't found in the given path, deal with it nicer (but
it is still likely to not do very good since it can't figure out all the lib dependencies)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5fe7c1943..cf6738b4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,7 @@ dnl We don't know the version number "staticly" so we use a dash here
AC_INIT(curl, [-], [a suitable curl mailing list => http://curl.haxx.se/mail/])
dnl configure script copyright
-AC_COPYRIGHT([Copyright (c) 1998 - 2004 Daniel Stenberg, <daniel@haxx.se>
+AC_COPYRIGHT([Copyright (c) 1998 - 2005 Daniel Stenberg, <daniel@haxx.se>
This configure script may be copied, distributed and modified under the
terms of the curl license; see COPYING for more details])
@@ -1011,8 +1011,11 @@ if test "$OPENSSL_ENABLED" != "1"; then
else
addlib="-L$OPT_GNUTLS/lib -lgnutls"
addcflags="-I$OPT_GNUTLS/include"
- version=`$OPT_GNUTLS/bin/libgnutls-config --version`
+ version=`$OPT_GNUTLS/bin/libgnutls-config --version 2>/dev/null`
gtlsprefix=$OPT_GNUTLS
+ if test -z "$version"; then
+ version="unknown"
+ fi
fi
CLEANLDFLAGS="$LDFLAGS"