summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2015-12-16 10:06:09 +0100
committerDaniel Stenberg <daniel@haxx.se>2015-12-16 10:06:09 +0100
commit1ff3a07be9b875155b0076a91a0b8f5c5fd22067 (patch)
tree2f0b2a7571cecb8ab90a0f79a65a68e611903dba /configure.ac
parent15cb03ad846a10c4aa4889d46804389ad11cdc1d (diff)
downloadcurl-1ff3a07be9b875155b0076a91a0b8f5c5fd22067.tar.gz
wolfssl: handle builds without SSLv3 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4c14e382e..3031f05ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2166,11 +2166,11 @@ if test "$curl_ssl_msg" = "$init_ssl_msg"; then
]])
],[
AC_MSG_RESULT(yes)
- AC_DEFINE(USE_CYASSL, 1, [if CyaSSL is enabled])
+ AC_DEFINE(USE_CYASSL, 1, [if CyaSSL/WolfSSL is enabled])
AC_SUBST(USE_CYASSL, [1])
CYASSL_ENABLED=1
USE_CYASSL="yes"
- curl_ssl_msg="enabled (CyaSSL)"
+ curl_ssl_msg="enabled (WolfSSL)"
],
[
AC_MSG_RESULT(no)
@@ -2195,6 +2195,11 @@ if test "$curl_ssl_msg" = "$init_ssl_msg"; then
LIBS="-l$cyassllibname -lm $LIBS"
+ if test "x$cyassllib" = "xwolfssl"; then
+ dnl Recent WolfSSL versions build without SSLv3 by default
+ AC_CHECK_FUNCS(wolfSSLv3_client_method)
+ fi
+
if test -n "$cyassllib"; then
dnl when shared libs were found in a path that the run-time
dnl linker doesn't search through, we need to add it to