summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2021-03-10 00:38:21 +0100
committerDaniel Stenberg <daniel@haxx.se>2021-03-11 10:12:30 +0100
commitdcccd8dd25a8e9d476f9bda94f9ebfd0b9f472db (patch)
treeb609b2e96f31905a656bc2651fd387d5effd87af /configure.ac
parent78f642ffab9a703bb23e4d9ddb1abe582f14eb62 (diff)
downloadcurl-dcccd8dd25a8e9d476f9bda94f9ebfd0b9f472db.tar.gz
configure: provide Largefile feature for curl-config
... as cmake now does it correctly, and make test1014 check for it Closes #6702
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1af9d0f41..f3b11f005 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5262,6 +5262,13 @@ if test "x$ECH_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES ECH"
fi
+if test ${ac_cv_sizeof_curl_off_t} -gt 4; then
+ if test ${ac_cv_sizeof_off_t} -gt 4 -o \
+ "$curl_win32_file_api" = "win32_large_files"; then
+ SUPPORT_FEATURES="$SUPPORT_FEATURES Largefile"
+ fi
+fi
+
dnl replace spaces with newlines
dnl sort the lines
dnl replace the newlines back to spaces