summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-10-05 10:16:40 +0200
committerDaniel Stenberg <daniel@haxx.se>2017-10-09 11:29:53 +0200
commit62a721ea47e1e697faa7e3d87c8c9025808a8667 (patch)
tree31acc246f817519a1f8373a345bd9430ce12d3ab /configure.ac
parentc95c92da7584483368c8761c8cca276b5401530c (diff)
downloadcurl-62a721ea47e1e697faa7e3d87c8c9025808a8667.tar.gz
openssl: enable PKCS12 support for !BoringSSL
Enable PKCS12 for all non-boringssl builds without relying on configure or cmake checks. Bug: https://curl.haxx.se/mail/lib-2017-10/0007.html Reported-by: Christian Schmitz Closes #1948
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 56b8756ba..8d71bb6fc 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1647,10 +1647,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
fi
fi
- if test X"$OPENSSL_ENABLED" = X"1"; then
- dnl is there a pkcs12.h header present?
- AC_CHECK_HEADERS(openssl/pkcs12.h)
- else
+ if test X"$OPENSSL_ENABLED" != X"1"; then
LIBS="$CLEANLIBS"
fi