summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2009-03-13 09:58:15 +0000
committerDaniel Stenberg <daniel@haxx.se>2009-03-13 09:58:15 +0000
commit74ba4d7950fa001d0a9dddfddacb240ae2c69c6c (patch)
treea73ec97082c4b6492b4c5189d62ab468b089a50f /configure.ac
parentfa9643666128a8ed60e22d4e0fa56e8638726d23 (diff)
downloadcurl-74ba4d7950fa001d0a9dddfddacb240ae2c69c6c.tar.gz
- Use libssh2_version() to present the libssh2 version in case the libssh2
library is found to support it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af652655a..d9ff3de8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1494,6 +1494,9 @@ if test X"$OPT_LIBSSH2" != Xno; then
dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
dnl to prevent further configure tests to fail due to this
+ dnl libssh2_version is a post 1.0 addition
+ AC_CHECK_FUNCS( libssh2_version )
+
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_LIBSSH2"
export LD_LIBRARY_PATH
AC_MSG_NOTICE([Added $LIB_LIBSSH2 to LD_LIBRARY_PATH])