summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2021-07-29 23:27:30 +0200
committerDaniel Stenberg <daniel@haxx.se>2021-08-08 22:57:29 +0200
commit26c002bf7c965f7df2570479e352d50f637835d1 (patch)
treed19e1b638c7b5ff41dc46c8fa79c6fadcc5f23bb /configure.ac
parenta2e29f07317c521f9d4fb06b6f1f3c235bb2e2bf (diff)
downloadcurl-26c002bf7c965f7df2570479e352d50f637835d1.tar.gz
configure.ac: revert bad nghttp2 library detection improvements
This reverts commit b4b34db65f9f8, 673753344c5f and 29c7cf79e8b. The logic is now back to assuming that the nghttp2 lib is called nghttp2 and nothing else. Reported-by: Rui Pinheiro Reported-by: Alex Crichton Fixes #7514 Closes #7515
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c92ab9e22..3d8c0d1d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2541,11 +2541,10 @@ if test X"$want_h2" != Xno; then
LDFLAGS="$LDFLAGS $LD_H2"
CPPFLAGS="$CPPFLAGS $CPP_H2"
LIBS="$LIB_H2 $LIBS"
- LIB_H2_NAME=`echo $LIB_H2 | $SED -ne 's/.*-l *\(nghttp2[^ ]*\).*/\1/p'`
# use nghttp2_session_set_local_window_size to require nghttp2
# >= 1.12.0
- AC_CHECK_LIB($LIB_H2_NAME, nghttp2_session_set_local_window_size,
+ AC_CHECK_LIB(nghttp2, nghttp2_session_set_local_window_size,
[
AC_CHECK_HEADERS(nghttp2/nghttp2.h,
curl_h2_msg="enabled (nghttp2)"