summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2009-06-08 21:12:59 +0000
committerDaniel Stenberg <daniel@haxx.se>2009-06-08 21:12:59 +0000
commitf90551ff413b9c343443eecaea56c9503442ed31 (patch)
treedbff4ece38cc25f7b0adac4efd7644fd1394d69f /configure.ac
parent9442fc0b5281c1b77a28571dc327b9043c42ca2e (diff)
downloadcurl-f90551ff413b9c343443eecaea56c9503442ed31.tar.gz
- Triggered by bug report #2798852 and the patch in there, I fixed configure
to detect gnutls build options with pkg-config only and not libgnutls-config anymore since GnuTLS has stopped distributing that tool. If an explicit path is given to configure, we will instead guess on how to link and use that lib. I did not use the patch from the bug report.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 7 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index c71082886..049df2439 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1554,25 +1554,8 @@ if test "$OPENSSL_ENABLED" != "1"; then
if test X"$OPT_GNUTLS" != Xno; then
- AC_MSG_NOTICE([OPT_GNUTLS is $OPT_GNUTLS])
-
addld=""
if test "x$OPT_GNUTLS" = "xyes"; then
- check=`libgnutls-config --version 2>/dev/null`
- if test -n "$check"; then
- addlib=`libgnutls-config --libs`
- addcflags=`libgnutls-config --cflags`
- version=`libgnutls-config --version`
- gtlslib=`libgnutls-config --prefix`/lib$libsuff
- fi
- else
- addlib=`$OPT_GNUTLS/bin/libgnutls-config --libs`
- addcflags=`$OPT_GNUTLS/bin/libgnutls-config --cflags`
- version=`$OPT_GNUTLS/bin/libgnutls-config --version 2>/dev/null`
- gtlslib=$OPT_GNUTLS/lib$libsuff
- fi
-
- if test -z "$version"; then
CURL_CHECK_PKGCONFIG(gnutls)
if test "$PKGCONFIG" != "no" ; then
@@ -1582,7 +1565,13 @@ if test "$OPENSSL_ENABLED" != "1"; then
version=`$PKGCONFIG --modversion gnutls`
gtlslib=`echo $addld | $SED -e 's/-L//'`
fi
-
+ else
+ dnl without pkg-config, we guess a lot!
+ addlib=-lgnutls
+ addld=-L$OPT_GNUTLS/lib$libsuff
+ addcflags=-I$OPT_GNUTLS/include
+ version="" # we just don't know
+ gtlslib=$OPT_GNUTLS/lib$libsuff
fi
if test -z "$version"; then