summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2010-03-05 22:53:30 +0000
committerDaniel Stenberg <daniel@haxx.se>2010-03-05 22:53:30 +0000
commitf5d8c0befc61497b3d3572ae51e779b396589660 (patch)
tree177d9c126c5939d99c085e5eb98c91e3da5841d3 /configure.ac
parent21f331ead265b1f02ae14fd03e9af53ea5b7bd55 (diff)
downloadcurl-f5d8c0befc61497b3d3572ae51e779b396589660.tar.gz
Daniel Johnson provided fixes for building with the clang compiler
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2320dce4d..727e389b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2380,7 +2380,10 @@ AC_HELP_STRING([--disable-hidden-symbols],[Leave all symbols with default visibi
*)
AC_MSG_CHECKING([whether $CC supports it])
if test "$GCC" = yes ; then
- if $CC --help --verbose 2>&1 | grep fvisibility= > /dev/null ; then
+ if $CC --help --verbose 2>&1 | grep fvisibility= > /dev/null ||
+ dnl clang always supports -fvisibility= but it doesn't show up
+ dnl under --help.
+ test "$compiler_id" = "CLANG"; then
AC_MSG_RESULT(yes)
AC_DEFINE(CURL_HIDDEN_SYMBOLS, 1, [to enable hidden symbols])
AC_DEFINE(CURL_EXTERN_SYMBOL, [__attribute__ ((visibility ("default")))], [to make a symbol visible])