summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2019-01-29 10:09:29 +0100
committerDaniel Stenberg <daniel@haxx.se>2019-02-01 08:20:38 +0100
commit180501cb0220c8451a38dc8ae04b6c58743025a8 (patch)
treee9ae4a63105fa04f0c779db3ea91a1e25fc571f1 /configure.ac
parent6f61933adfa60236ae2b5c57ddfdf3e3a36dcc2a (diff)
downloadcurl-180501cb0220c8451a38dc8ae04b6c58743025a8.tar.gz
schannel: stop calling it "winssl"
Stick to "Schannel" everywhere. The configure option --with-winssl is kept to allow existing builds to work but --with-schannel is added as an alias. Closes #3504
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c099ab94e..e9f0ef75b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1480,6 +1480,11 @@ AC_HELP_STRING([--with-winssl],[enable Windows native SSL/TLS])
AC_HELP_STRING([--without-winssl], [disable Windows native SSL/TLS]),
OPT_WINSSL=$withval)
+AC_ARG_WITH(schannel,dnl
+AC_HELP_STRING([--with-schannel],[enable Windows native SSL/TLS])
+AC_HELP_STRING([--without-schannel], [disable Windows native SSL/TLS]),
+ OPT_WINSSL=$withval)
+
AC_MSG_CHECKING([whether to enable Windows native SSL/TLS (Windows native builds only)])
if test -z "$ssl_backends" -o "x$OPT_WINSSL" != xno; then
ssl_msg=