summaryrefslogtreecommitdiff
path: root/ares/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2006-05-24 23:02:51 +0000
committerDaniel Stenberg <daniel@haxx.se>2006-05-24 23:02:51 +0000
commitc60621c367f99af10cb1acda558f0b53a7903278 (patch)
tree91f4516a50c359aea2adf0adbd48ef0d2b156585 /ares/configure.ac
parent606562aa7ea28ee0fdd5bf2cd6febada9594ad19 (diff)
downloadcurl-c60621c367f99af10cb1acda558f0b53a7903278.tar.gz
Copied the NO_UNDEFINED magic from libcurl to make this build fine again with
libtool cross-compiled on linux with mingw32
Diffstat (limited to 'ares/configure.ac')
-rw-r--r--ares/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/ares/configure.ac b/ares/configure.ac
index f862f8bf3..8f903a300 100644
--- a/ares/configure.ac
+++ b/ares/configure.ac
@@ -69,6 +69,18 @@ dnl libtool setup
CARES_CLEAR_LIBTOOL_TAGS
AC_PROG_LIBTOOL
+AC_MSG_CHECKING([if we need -no-undefined])
+case $host in
+ *-*-cygwin | *-*-mingw* | *-*-pw32*)
+ need_no_undefined=yes
+ ;;
+ *)
+ need_no_undefined=no
+ ;;
+esac
+AC_MSG_RESULT($need_no_undefined)
+AM_CONDITIONAL(NO_UNDEFINED, test x$need_no_undefined = xyes)
+
dnl Checks for header files.
AC_HEADER_STDC