summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2001-01-08 22:18:30 +0000
committerDaniel Stenberg <daniel@haxx.se>2001-01-08 22:18:30 +0000
commita997d60304c8f3cbcdad5d5cf5b277d19e5325eb (patch)
tree5de2a5724994323c0714bd978c5f5f1e6aee67e7 /Makefile.am
parentff8fb8cdb04d7d18fea9122e1167fd9f1dc472ec (diff)
downloadcurl-a997d60304c8f3cbcdad5d5cf5b277d19e5325eb.tar.gz
Loic Dachary's updates to get 'make distcheck' work, including running the
test suite
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 415bde30c..b2270a47e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,13 +6,15 @@ AUTOMAKE_OPTIONS = foreign no-dependencies
EXTRA_DIST = \
CHANGES LEGAL maketgz MITX.txt MPL-1.1.txt \
- config-win32.h reconf packages/README
+ config-win32.h reconf packages/README Makefile.dist
SUBDIRS = docs lib src include tests packages
# create a root makefile in the distribution:
dist-hook:
- cp Makefile.dist $(distdir)/Makefile
+ cp $(srcdir)/Makefile.dist $(distdir)/Makefile
+
+check: test
test:
@(cd tests; make quiet-test)