summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2001-01-08 10:00:14 +0000
committerDaniel Stenberg <daniel@haxx.se>2001-01-08 10:00:14 +0000
commit044ca343adbd4686b6ef71ebfb087e7dcceffe61 (patch)
tree5e1e461eab790a0cef0c396acbfe72a763fc5b1a /Makefile.am
parentf59ea9adb3b6cecad5218e9970bc7ca48ffdd2b2 (diff)
downloadcurl-044ca343adbd4686b6ef71ebfb087e7dcceffe61.tar.gz
Loic Dachary's makefile/dist/rpm fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f9a66936..5b85fb57e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,9 +4,35 @@
AUTOMAKE_OPTIONS = foreign no-dependencies
-EXTRA_DIST = curl.spec curl-ssl.spec
+EXTRA_DIST = curl.spec curl-ssl.spec \
+ CHANGES FILES LEGAL MITX.txt MPL-1.1.txt \
+ config-win32.h reconf
SUBDIRS = docs lib src include tests
test:
@(cd tests; make quiet-test)
+
+# Build source and binary rpms. For rpm-3.0 and above, the ~/.rpmmacros
+# must contain the following line:
+# %_topdir /home/loic/local/rpm
+# and that /home/loic/local/rpm contains the directory SOURCES, BUILD etc.
+#
+# If additional configure flags are needed to build the package, add the
+# following in ~/.rpmmacros
+# %configure CFLAGS="%{optflags}" ./configure %{_target_platform} --prefix=%{_prefix} ${AM_CONFIGFLAGS}
+# and run make rpm in the following way:
+# AM_CONFIGFLAGS='--with-uri=/home/users/loic/local/RedHat-6.2' make rpm
+#
+
+rpms:
+ $(MAKE) RPMDIST=curl rpm
+ $(MAKE) RPMDIST=curl-ssl rpm
+
+rpm:
+ RPM_TOPDIR=`rpm --showrc | $(PERL) -n -e 'print if(s/.*_topdir\s+(.*)/$$1/)'` ; \
+ cp $(srcdir)/$(RPMDIST).spec $$RPM_TOPDIR/SPECS ; \
+ cp $(PACKAGE)-$(VERSION).tar.gz $$RPM_TOPDIR/SOURCES ; \
+ rpm -ba --clean --rmsource $$RPM_TOPDIR/SPECS/$(RPMDIST).spec ; \
+ mv $$RPM_TOPDIR/RPMS/i386/$(RPMDIST)-*.rpm . ; \
+ mv $$RPM_TOPDIR/SRPMS/$(RPMDIST)-*.src.rpm .