summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCris Bailiff <c.bailiff@awayweb.com>2001-05-30 04:31:32 +0000
committerCris Bailiff <c.bailiff@awayweb.com>2001-05-30 04:31:32 +0000
commitc503930b8d5bc62b011961dd5e0b27f80362c322 (patch)
tree90683b6b520033843844b0d68f8aa6b497eac1a4 /Makefile.am
parent5c6859e537bd08b6c34f91a82a03104a79dea9df (diff)
downloadcurl-c503930b8d5bc62b011961dd5e0b27f80362c322.tar.gz
Added Solaris 'pkgadd' building support to packages collection and autoconf/automake files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ae4b11e52..22b65df94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,3 +48,18 @@ rpm:
rpm -ba --clean --rmsource $$RPM_TOPDIR/SPECS/$(RPMDIST).spec ; \
mv $$RPM_TOPDIR/RPMS/i386/$(RPMDIST)-*.rpm . ; \
mv $$RPM_TOPDIR/SRPMS/$(RPMDIST)-*.src.rpm .
+
+#
+# Build a Solaris pkkgadd format file
+# run 'make pkgadd' once you've done './configure' and 'make' to make a Solaris pkgadd format
+# file (which ends up back in this directory).
+# The pkgadd file is in 'pkgtrans' format, so to install on Solaris, do
+# pkgadd -d ./HAXXcurl-*
+#
+
+# gak - libtool requires an absoulte directory, hence the pwd below...
+pkgadd:
+ umask 022 ; \
+ make install DESTDIR=`/bin/pwd`/packages/Solaris/root ; \
+ cat LEGAL MITX.txt MPL-1.1.txt > $(srcdir)/packages/Solaris/copyright ; \
+ cd $(srcdir)/packages/Solaris && $(MAKE) package