summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2003-10-30 12:48:19 +0000
committerDaniel Stenberg <daniel@haxx.se>2003-10-30 12:48:19 +0000
commit36d6b16c236ad957e733b14a5a811b0adedf1460 (patch)
tree1e6c666eeea78d1ae1c56ce56e5fa6910211e53d /Makefile.am
parentb4d8108ba10ca857ea1b8fd94f610cebc47672e7 (diff)
downloadcurl-36d6b16c236ad957e733b14a5a811b0adedf1460.tar.gz
Made the dist-hook more generic for adding more files named .dist into the
dist archive. Preparing for a new maketgz.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a48c323cf..ee4149323 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,10 +13,14 @@ bin_SCRIPTS = curl-config
SUBDIRS = lib src
DIST_SUBDIRS = $(SUBDIRS) tests include packages docs
-# create a root makefile in the distribution:
dist-hook:
rm -rf $(top_builddir)/tests/log
- cp $(srcdir)/Makefile.dist $(distdir)/Makefile
+ find $(distdir) -name "*.dist" -exec rm {} \;
+ (distit=`find $(srcdir) -name "*.dist"`; \
+ for file in $$distit; do \
+ strip=`echo $$file | sed -e s/^$(srcdir)// -e s/\.dist//`; \
+ cp $$file $(distdir)$$strip; \
+ done)
html:
cd docs; make html