summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Pappacoda <andrea@pappacoda.it>2021-07-04 20:13:50 +0200
committerDaniel Stenberg <daniel@haxx.se>2021-07-05 22:44:00 +0200
commit4f3828d5a2482a3eed76219bbe8d5f896e990e2a (patch)
tree07ccf7311c1a247be0e3c6a6698e058cab2687b8 /CMakeLists.txt
parente41feede34cf5259d6b2693c05a10dad5c000f32 (diff)
downloadcurl-4f3828d5a2482a3eed76219bbe8d5f896e990e2a.tar.gz
cmake: remove libssh2 feature checks
libssh2 features are detected based on version since commit 9dbbba997608f7c3c5de1c627c77c8cd2aa85b73 Closes #7343
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffdc01c3b..c85295e11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -716,15 +716,6 @@ if(CMAKE_USE_LIBSSH2)
set(HAVE_LIBSSH2_H ON)
set(CURL_INCLUDES ${CURL_INCLUDES} "${LIBSSH2_INCLUDE_DIR}/libssh2.h")
set(CURL_TEST_DEFINES "${CURL_TEST_DEFINES} -DHAVE_LIBSSH2_H")
-
- # now check for specific libssh2 symbols as they were added in different versions
- set(CMAKE_EXTRA_INCLUDE_FILES "libssh2.h")
- check_function_exists(libssh2_version HAVE_LIBSSH2_VERSION)
- check_function_exists(libssh2_init HAVE_LIBSSH2_INIT)
- check_function_exists(libssh2_exit HAVE_LIBSSH2_EXIT)
- check_function_exists(libssh2_scp_send64 HAVE_LIBSSH2_SCP_SEND64)
- check_function_exists(libssh2_session_handshake HAVE_LIBSSH2_SESSION_HANDSHAKE)
- set(CMAKE_EXTRA_INCLUDE_FILES "")
unset(CMAKE_REQUIRED_LIBRARIES)
endif()
endif()