summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRazvan Cojocaru <rzvncj@gmail.com>2021-01-11 13:00:36 +0200
committerJay Satiro <raysatiro@yahoo.com>2021-01-16 02:18:12 -0500
commit13fe0b6ade262e6ae5e595478b5bfcded86406ea (patch)
tree40d493a8ae676cd7fd503d73716275453ce2fc24 /CMakeLists.txt
parent30e7641d7d2eb46c0b67c0c495a0ea7e52333ee2 (diff)
downloadcurl-13fe0b6ade262e6ae5e595478b5bfcded86406ea.tar.gz
cmake: expose CURL_DISABLE_OPENSSL_AUTO_LOAD_CONFIG
This does for cmake builds what --disable-openssl-auto-load-config does for autoconf builds. Closes https://github.com/curl/curl/pull/6435
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58f4bfb7c..2384cd49e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -337,6 +337,7 @@ if(WIN32 OR CMAKE_USE_SECTRANSP OR CMAKE_USE_SCHANNEL OR CMAKE_USE_MBEDTLS OR CM
set(openssl_default OFF)
endif()
option(CMAKE_USE_OPENSSL "Use OpenSSL code. Experimental" ${openssl_default})
+option(CURL_DISABLE_OPENSSL_AUTO_LOAD_CONFIG "Disable automatic loading of OpenSSL configuration" OFF)
count_true(enabled_ssl_options_count
CMAKE_USE_SCHANNEL