summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKlaus Crusius <klaus.crusius@web.de>2020-11-28 18:17:11 +0100
committerDaniel Stenberg <daniel@haxx.se>2020-12-01 12:32:55 +0100
commitd6bfbfadd30984737f4481087678219be88fc5f7 (patch)
tree93a4fcdffcdf72278768028274091f8d7e9f9a40 /CMakeLists.txt
parent221c9da9af187a69ff5775ca95bc5ce5f10ba41d (diff)
downloadcurl-d6bfbfadd30984737f4481087678219be88fc5f7.tar.gz
cmake: check for linux/tcp.h
The HAVE_LINUX_TCP_H define was not set by cmake. Closes #6252
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a2ad440b..6a1a6fe8e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -909,6 +909,7 @@ check_include_file_concat("net/if.h" HAVE_NET_IF_H)
check_include_file_concat("netdb.h" HAVE_NETDB_H)
check_include_file_concat("netinet/in.h" HAVE_NETINET_IN_H)
check_include_file_concat("netinet/tcp.h" HAVE_NETINET_TCP_H)
+check_include_file("linux/tcp.h" HAVE_LINUX_TCP_H)
check_include_file_concat("pem.h" HAVE_PEM_H)
check_include_file_concat("poll.h" HAVE_POLL_H)