summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Zajic <radek.zajic@showmax.com>2021-05-24 16:38:40 +0200
committerDaniel Stenberg <daniel@haxx.se>2021-05-25 12:45:56 +0200
commit31f631a142d855f069242f3e0c643beec25d1b51 (patch)
treeaef4a898796ddf11f4d48dc80c445465c3784e66 /CMakeLists.txt
parenta63dae5d078b24dc441e421a37fa7daf09fc4768 (diff)
downloadcurl-31f631a142d855f069242f3e0c643beec25d1b51.tar.gz
lib/hostip6.c: make NAT64 address synthesis on macOS work
Closes #7121
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e06f1bbb..f5f560292 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -386,6 +386,14 @@ if(CMAKE_USE_SECTRANSP)
list(APPEND CURL_LIBS "${COREFOUNDATION_FRAMEWORK}" "${SECURITY_FRAMEWORK}")
endif()
+if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ find_library(SYSTEMCONFIGURATION_FRAMEWORK "SystemConfiguration")
+ if(NOT SYSTEMCONFIGURATION_FRAMEWORK)
+ message(FATAL_ERROR "SystemConfiguration framework not found")
+ endif()
+ list(APPEND CURL_LIBS "${SYSTEMCONFIGURATION_FRAMEWORK}")
+endif()
+
if(CMAKE_USE_OPENSSL)
find_package(OpenSSL REQUIRED)
set(SSL_ENABLED ON)