summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcel Raad <Marcel.Raad@teamviewer.com>2021-09-29 14:52:38 +0200
committerMarcel Raad <Marcel.Raad@teamviewer.com>2021-09-29 15:54:36 +0200
commit2bde1774fff9e88958238c0ff1dec0de76f97f8b (patch)
tree2ff7a4f649cf6520c90d7ad1c9d0e418560a25ef /CMakeLists.txt
parent60300291fdd62a0b808c78942a2ce0aae872cab0 (diff)
downloadcurl-2bde1774fff9e88958238c0ff1dec0de76f97f8b.tar.gz
CMake: remove `HAVE_WINSOCK_H` definition
It's not used anymore. Closes https://github.com/curl/curl/pull/7795
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf9c390c3..58e3c0366 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -910,7 +910,6 @@ endif()
# Check for header files
if(NOT UNIX)
check_include_file_concat("windows.h" HAVE_WINDOWS_H)
- check_include_file_concat("winsock.h" HAVE_WINSOCK_H)
check_include_file_concat("ws2tcpip.h" HAVE_WS2TCPIP_H)
check_include_file_concat("winsock2.h" HAVE_WINSOCK2_H)
check_include_file_concat("wincrypt.h" HAVE_WINCRYPT_H)