summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2010-06-04 15:14:31 +0200
committerYang Tse <yangsita@gmail.com>2010-06-04 15:14:31 +0200
commit43d20d81a55a0e30becea04b7e607775093ce6eb (patch)
tree4bff0680c51839d1d494befaa2e66230021b2ae4 /CMakeLists.txt
parentbc0f3dd15e99db189ae38c04ac660a174b7c27ec (diff)
downloadcurl-43d20d81a55a0e30becea04b7e607775093ce6eb.tar.gz
Enable OpenLDAP support for cygwin builds.
Enable OpenLDAP support for cygwin builds. This support was disabled back in 2008 due to incompatibilities between OpenSSL and OpenLDAP headers. cygwin's OpenSSL 0.9.8l and OpenLDAP 2.3.43 versions on cygwin 1.5.25 allow building an OpenLDAP enabled libcurl supporting back to Windows 95. Remove non-functional CURL_LDAP_HYBRID code and references.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56c42785f..a9bde719a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,16 +120,11 @@ if(WIN32)
if( NOT HAVE_WLDAP32)
set(CURL_DISABLE_LDAP ON CACHE BOOL "" FORCE)
message(STATUS "wldap32 not found CURL_DISABLE_LDAP set ON")
- option(CURL_LDAP_WIN "Use W$ LDAP implementation" OFF)
+ option(CURL_LDAP_WIN "Use Windows LDAP implementation" OFF)
else()
- option(CURL_LDAP_WIN "Use W$ LDAP implementation" ON)
+ option(CURL_LDAP_WIN "Use Windows LDAP implementation" ON)
endif()
mark_as_advanced(CURL_LDAP_WIN)
- set(CURL_LDAP_HYBRID OFF)
-else()
- option(CURL_LDAP_HYBRID "W$ LDAP with non-W$ compiler" OFF)
- mark_as_advanced(CURL_LDAP_HYBRID)
- set(CURL_LDAP_WIN OFF)
endif()
if(HTTP_ONLY)