summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Satiro <raysatiro@yahoo.com>2018-01-03 14:40:52 -0500
committerJay Satiro <raysatiro@yahoo.com>2018-01-05 23:34:30 -0500
commit908a9a6742b1010894fae2a4a9cf797b051d6c33 (patch)
treecb5381a70d543910de2b21b7bddf69702369c7cf /CMakeLists.txt
parent129390a518c41739364081c8966a718f2ac347a4 (diff)
downloadcurl-908a9a6742b1010894fae2a4a9cf797b051d6c33.tar.gz
build: remove HAVE_LIMITS_H check
.. because limits.h presence isn't optional, it's required by C89. Ref: http://port70.net/~nsz/c/c89/c89-draft.html#2.2.4.2 Closes https://github.com/curl/curl/pull/2215
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b73b98f7..490cc19ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -737,7 +737,6 @@ check_include_file_concat("ifaddrs.h" HAVE_IFADDRS_H)
check_include_file_concat("io.h" HAVE_IO_H)
check_include_file_concat("krb.h" HAVE_KRB_H)
check_include_file_concat("libgen.h" HAVE_LIBGEN_H)
-check_include_file_concat("limits.h" HAVE_LIMITS_H)
check_include_file_concat("locale.h" HAVE_LOCALE_H)
check_include_file_concat("net/if.h" HAVE_NET_IF_H)
check_include_file_concat("netdb.h" HAVE_NETDB_H)