summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ed2f613c63..d0821916ac 100644
--- a/configure.in
+++ b/configure.in
@@ -1437,6 +1437,12 @@ fi
if test "$use_lfs" = "yes"; then
# Two defines needed to enable largefile support on various platforms
# These may affect some typedefs
+case $ac_sys_system/$ac_sys_release in
+AIX*)
+ AC_DEFINE(_LARGE_FILES, 1,
+ [This must be defined on AIX systems to enable large file support.])
+ ;;
+esac
AC_DEFINE(_LARGEFILE_SOURCE, 1,
[This must be defined on some systems to enable large file support.])
AC_DEFINE(_FILE_OFFSET_BITS, 64,
@@ -2042,7 +2048,7 @@ AC_CHECK_LIB(intl, textdomain,
case "$ac_sys_system" in
AIX*) AC_MSG_CHECKING(for genuine AIX C++ extensions support)
AC_LINK_IFELSE([
- AC_LANG_PROGRAM([[#include "/usr/lpp/xlC/include/load.h"]],
+ AC_LANG_PROGRAM([[#include <load.h>]],
[[loadAndInit("", 0, "")]])
],[
AC_DEFINE(AIX_GENUINE_CPLUSPLUS, 1,