summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2013-11-24 19:44:57 +0100
committerStefan Krah <skrah@bytereef.org>2013-11-24 19:44:57 +0100
commit989b513394a22ca150b7ba718debb202ef491b95 (patch)
tree2e5e43bbcf84c156ccbebcbf30868a0a4db44257 /setup.py
parent901b549ff19913b7dd66e515d946bdf2bf991a1b (diff)
downloadcpython-989b513394a22ca150b7ba718debb202ef491b95.tar.gz
1) Prepare libmpdec for the 2.4.0 release. None of the following changes affects
_decimal: o Make all "mpd_t to C integer" conversion functions available in both the 64-bit and the 32-bit versions. o Make all mixed mpd_t/C integer arithmetic functions available in the 32-bit version. o Better handling of __STDC_LIMIT_MACROS for C++ users. o Add struct tags (at the request of C++ users). 2) Check for libmpdec.so.2 if --with-system-libmpdec is used.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 19a7b291e1..906401404d 100644
--- a/setup.py
+++ b/setup.py
@@ -1945,7 +1945,7 @@ class PyBuildExt(build_ext):
undef_macros = []
if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
include_dirs = []
- libraries = ['mpdec']
+ libraries = [':libmpdec.so.2']
sources = ['_decimal/_decimal.c']
depends = ['_decimal/docstrings.h']
else: