summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. L?wis <martin@v.loewis.de>2014-01-03 14:05:06 +0100
committerMartin v. L?wis <martin@v.loewis.de>2014-01-03 14:05:06 +0100
commit800e46c2f1bb98bf07fa5960145f3d6018fa56b3 (patch)
treefd2eaee5aea32c074ccc978fd72ff8d914ebc137 /setup.py
parent18bc52cf70c8618e6c67334b6b544dedcb9828dd (diff)
downloadcpython-800e46c2f1bb98bf07fa5960145f3d6018fa56b3.tar.gz
* Issue #16113: Remove sha3 module again.
Patch by Christian Heimes, with modifications.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index d7f52afc81..102d4ea8bc 100644
--- a/setup.py
+++ b/setup.py
@@ -827,15 +827,6 @@ class PyBuildExt(build_ext):
exts.append( Extension('_sha1', ['sha1module.c'],
depends=['hashlib.h']) )
- # SHA-3 (Keccak) module
- sha3_depends = ['hashlib.h']
- keccak = os.path.join(os.getcwd(), srcdir, 'Modules', '_sha3',
- 'keccak')
- for pattern in ('*.c', '*.h', '*.macros'):
- sha3_depends.extend(glob(os.path.join(keccak, pattern)))
- exts.append(Extension("_sha3", ["_sha3/sha3module.c"],
- depends=sha3_depends))
-
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
# your machine, though none are defined by default because of library