summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2006-04-13 19:19:01 +0000
committerGregory P. Smith <greg@mad-scientist.com>2006-04-13 19:19:01 +0000
commitd807585772358fe3a9e10dd07bf5ab6247ffd33d (patch)
treef42dcf0e94191fd2d1b05b436258d7f3c14f5fa5 /setup.py
parent50a0473c8553ae8e1ec651f69d828b44cdffd8a7 (diff)
downloadcpython-d807585772358fe3a9e10dd07bf5ab6247ffd33d.tar.gz
raise the minimum supported BerkeleyDB version to 3.3 and add notes to
news about this and a couple other recent fixes.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 5 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 3681589d07..61c1fec6df 100644
--- a/setup.py
+++ b/setup.py
@@ -571,14 +571,13 @@ class PyBuildExt(build_ext):
# Sleepycat Berkeley DB interface. http://www.sleepycat.com
#
- # This requires the Sleepycat DB code. The earliest supported version
- # of that library is 3.2, the latest supported version is 4.4. A list
- # of available releases can be found at
- #
- # http://www.sleepycat.com/update/index.html
+ # This requires the Sleepycat DB code. The supported versions
+ # are set below. Visit http://www.sleepycat.com/ to download
+ # a release. Most open source OSes come with one or more
+ # versions of BerkeleyDB already installed.
max_db_ver = (4, 4)
- min_db_ver = (3, 2)
+ min_db_ver = (3, 3)
db_setup_debug = False # verbose debug prints from this script?
# construct a list of paths to look for the header file in on