summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2007-08-24 11:48:37 +0000
committerGeorg Brandl <georg@python.org>2007-08-24 11:48:37 +0000
commit1e2336e3541232223fda88bfb02706189a039a69 (patch)
tree1b0000c27e31f1e050189f7c9217b169cbd47602 /setup.py
parenta50921d7872b14e076969e6ceada4b020f0ed917 (diff)
downloadcpython-1e2336e3541232223fda88bfb02706189a039a69.tar.gz
Bug #1765375: fix stripping of unwanted LDFLAGS.
(backport from rev. 57389)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a983b3be25..65b32ea271 100644
--- a/setup.py
+++ b/setup.py
@@ -267,7 +267,8 @@ class PyBuildExt(build_ext):
# strip out double-dashes first so that we don't end up with
# substituting "--Long" to "-Long" and thus lead to "ong" being
# used for a library directory.
- env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1], '', env_val)
+ env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1],
+ ' ', env_val)
parser = optparse.OptionParser()
# Make sure that allowing args interspersed with options is
# allowed