summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2006-08-06 22:07:04 +0000
committerAndrew M. Kuchling <amk@amk.ca>2006-08-06 22:07:04 +0000
commit041ace308e082bde43c78d2c7195eaf6b2b14dc9 (patch)
treefd875df6983c66cc8cad8e549ef582d0cf833259 /setup.py
parentb9e9ec853e0c85ec037a04fb3fb4924ac872a33f (diff)
downloadcpython-041ace308e082bde43c78d2c7195eaf6b2b14dc9.tar.gz
[Patch #1464056] Ensure that we use the panelw library when linking with ncursesw.
Once I see how the buildbots react, I'll backport this to 2.4.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 67ddade9d9..1ee370a401 100644
--- a/setup.py
+++ b/setup.py
@@ -902,8 +902,12 @@ class PyBuildExt(build_ext):
# Curses support, requiring the System V version of curses, often
# provided by the ncurses library.
+ panel_library = 'panel'
if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
curses_libs = ['ncursesw']
+ # Bug 1464056: If _curses.so links with ncursesw,
+ # _curses_panel.so must link with panelw.
+ panel_library = 'panelw'
exts.append( Extension('_curses', ['_cursesmodule.c'],
libraries = curses_libs) )
elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
@@ -926,9 +930,9 @@ class PyBuildExt(build_ext):
# If the curses module is enabled, check for the panel module
if (module_enabled(exts, '_curses') and
- self.compiler.find_library_file(lib_dirs, 'panel')):
+ self.compiler.find_library_file(lib_dirs, panel_library)):
exts.append( Extension('_curses_panel', ['_curses_panel.c'],
- libraries = ['panel'] + curses_libs) )
+ libraries = [panel_library] + curses_libs) )
# Andrew Kuchling's zlib module. Note that some versions of zlib