summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2010-08-08 17:56:41 +0000
committerThomas Heller <theller@ctypes.org>2010-08-08 17:56:41 +0000
commitaea67995767979fa7426f43a674c88587f2c7513 (patch)
tree806c977ab8f9febffdd433d5f9a648e7c4ff904c /setup.py
parent34907977f6345e356eb4f07034aa51677bdd7f8b (diff)
downloadcpython-aea67995767979fa7426f43a674c88587f2c7513.tar.gz
Fis issue5504: ctypes does now work with systems where mmap can't be
PROT_WRITE and PROT_EXEC.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a363509fbd..7d5d30c2cb 100644
--- a/setup.py
+++ b/setup.py
@@ -1867,8 +1867,7 @@ class PyBuildExt(build_ext):
'_ctypes/callbacks.c',
'_ctypes/callproc.c',
'_ctypes/stgdict.c',
- '_ctypes/cfield.c',
- '_ctypes/malloc_closure.c']
+ '_ctypes/cfield.c']
depends = ['_ctypes/ctypes.h']
if sys.platform == 'darwin':