summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthony Baxter <anthonybaxter@gmail.com>2006-04-09 15:07:40 +0000
committerAnthony Baxter <anthonybaxter@gmail.com>2006-04-09 15:07:40 +0000
commit004caa5dd08517fb320ce57a790567651b6a6dac (patch)
tree966834d6a88e75180fb79a5fe3dc030ec33edf3e /setup.py
parentf3f49da24c3b94e18c686277c7110828b74bcd7e (diff)
downloadcpython-004caa5dd08517fb320ce57a790567651b6a6dac.tar.gz
Python on OS X 10.3 and above now uses dlopen() (via dynload_shlib.c)
to load extension modules and now provides the dl module. As a result, sys.setdlopenflags() now works correctly on these systems. (SF patch #1454844)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 065a115878..eea9ee8aad 100644
--- a/setup.py
+++ b/setup.py
@@ -969,7 +969,7 @@ class PyBuildExt(build_ext):
if sys.maxint == 0x7fffffff:
# This requires sizeof(int) == sizeof(long) == sizeof(char*)
dl_inc = find_file('dlfcn.h', [], inc_dirs)
- if (dl_inc is not None) and (platform not in ['atheos', 'darwin']):
+ if (dl_inc is not None) and (platform not in ['atheos']):
exts.append( Extension('dl', ['dlmodule.c']) )
# Thomas Heller's _ctypes module