summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-03-06 10:42:21 +0100
committerGeorg Brandl <georg@python.org>2011-03-06 10:42:21 +0100
commite1e2033e397c7a3bd1192dae8bde4407ed901e8f (patch)
tree67287b2cc50209a566da6b27ba0dfdbbf30971c7 /configure.in
parenta230dea531230c14f5d98ab7d99726cb42210514 (diff)
downloadcpython-e1e2033e397c7a3bd1192dae8bde4407ed901e8f.tar.gz
Port build identification from default branch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d0821916ac..ea106b525f 100644
--- a/configure.in
+++ b/configure.in
@@ -853,6 +853,21 @@ else
SVNVERSION="echo Unversioned directory"
fi
+AC_SUBST(HGVERSION)
+AC_SUBST(HGTAG)
+AC_SUBST(HGBRANCH)
+AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+if test $HAS_HG = found
+then
+ HGVERSION="hg id -i \$(srcdir)"
+ HGTAG="hg id -t \$(srcdir)"
+ HGBRANCH="hg id -b \$(srcdir)"
+else
+ HGVERSION=""
+ HGTAG=""
+ HGBRANCH=""
+fi
+
case $MACHDEP in
bsdos*|hp*|HP*)
# install -d does not work on BSDI or HP-UX