summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2010-05-08 11:04:18 +0000
committerMatthias Klose <doko@ubuntu.com>2010-05-08 11:04:18 +0000
commite130c7a40254a55f049873ac14c90f929f614aab (patch)
treef9d9e87276129f92b84c35eaacbff3f968245855 /configure.in
parent0d00a87d0ea4ac7f320eee18d16b4939aaf5b922 (diff)
downloadcpython-e130c7a40254a55f049873ac14c90f929f614aab.tar.gz
configure.in: Avoid autoconf warning: Assume C89 semantics that
RETSIGTYPE is always void (issue #8510). pyconfig.h: Regenerate
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index cdd69d09bd..48c4eb3d86 100644
--- a/configure.in
+++ b/configure.in
@@ -1474,18 +1474,7 @@ EOF
AC_TYPE_MODE_T
AC_TYPE_OFF_T
AC_TYPE_PID_T
-AC_DIAGNOSE([obsolete],[your code may safely assume C89 semantics that RETSIGTYPE is void.
-Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
-AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
-[AC_LANG_PROGRAM([#include <sys/types.h>
-#include <signal.h>
-],
- [return *(signal (0, 0)) (0) == 1;])],
- [ac_cv_type_signal=int],
- [ac_cv_type_signal=void])])
-AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
- (`int' or `void').])
-
+AC_DEFINE_UNQUOTED([RETSIGTYPE],[void],[assume C89 semantics that RETSIGTYPE is always void])
AC_TYPE_SIZE_T
AC_TYPE_UID_T
AC_TYPE_UINT32_T