summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2000-12-13 17:37:02 +0000
committerMartin v. Löwis <martin@v.loewis.de>2000-12-13 17:37:02 +0000
commitba4b0ffa3951468f05d08e313bc060a7b8eaebfc (patch)
tree05f73b42404618d8faaddd320b096b6d670afa46 /configure.in
parenta7bae8e2c555ab3cb5f675ed29a3d27a4c0feb75 (diff)
downloadcpython-ba4b0ffa3951468f05d08e313bc060a7b8eaebfc.tar.gz
Set CXX even when --with-cxx is not specified. Closes bug #124782
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bf21e51584..07072c504b 100644
--- a/configure.in
+++ b/configure.in
@@ -153,6 +153,7 @@ AC_SUBST(MAINOBJ)
MAINOBJ=python.o
AC_MSG_CHECKING(for --with-cxx=<compiler>)
AC_ARG_WITH(cxx, [ --with-cxx=<compiler> enable C++ support],[
+ check_cxx=no
case $withval in
no) CXX=
with_cxx=no;;
@@ -161,10 +162,29 @@ AC_ARG_WITH(cxx, [ --with-cxx=<compiler> enable C++ support],[
with_cxx=$withval;;
esac], [
with_cxx=no
+ check_cxx=yes
])
AC_MSG_RESULT($with_cxx)
+
+dnl The following fragment works similar to AC_PROG_CXX.
+dnl It does not fail if CXX is not found, and it is not executed if
+dnl --with-cxx was given.
+dnl Finally, it does not test whether CXX is g++.
+
+if test "$check_cxx" = "yes"
+then
+ AC_CHECK_PROGS(CXX, $CCC c++ g++ gcc CC cxx cc++ cl, notfound)
+ if test "$CXX" = "notfound"
+ then
+ CXX=
+ else
+ AC_PROG_CXX_WORKS
+ fi
+fi
+
SET_CXX="CXX=$CXX"
+
#AC_MSG_CHECKING(CCC)
#if test -z "$CCC"
#then