summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2007-10-24 20:00:44 +0000
committerMatthias Klose <doko@ubuntu.com>2007-10-24 20:00:44 +0000
commitb19342cad3590b1d13f823b197a2b20c2fd850d6 (patch)
tree9552cfdfc7458db44462f72c46841101b9b63237 /configure.in
parent698a534cf02fea2aa179c363eacd246b0d306552 (diff)
downloadcpython-b19342cad3590b1d13f823b197a2b20c2fd850d6.tar.gz
- Build using system ffi library on arm*-linux*.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7480ee64a1..2c5a85fc12 100644
--- a/configure.in
+++ b/configure.in
@@ -1748,12 +1748,16 @@ LIBS="$withval $LIBS"
[AC_MSG_RESULT(no)])
# Check for use of the system libffi library
+AC_CHECK_HEADER(ffi.h)
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AC_HELP_STRING(--with-system-ffi, build _ctypes module using an installed ffi library))
-if test -z "$with_system_ffi"
-then with_system_ffi="no"
+if test -z "$with_system_ffi" && test "$ac_cv_header_ffi_h" = yes; then
+ case "$ac_sys_system/`uname -m`" in
+ Linux/arm*) with_system_ffi="yes";;
+ *) with_system_ffi="no"
+ esac
fi
AC_MSG_RESULT($with_system_ffi)