summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-06-03 07:37:13 +0000
committerMartin v. Löwis <martin@v.loewis.de>2006-06-03 07:37:13 +0000
commitaa793cf8a4b06ff056bf183c76db94dae5bbfeda (patch)
tree92908279e9d01b90519a02a020bc1fa299d37eb8 /configure.in
parent786c22eaf2ffc8dd0d8321a882685395b65bd57b (diff)
downloadcpython-aa793cf8a4b06ff056bf183c76db94dae5bbfeda.tar.gz
Port to OpenBSD 3.9. Patch from Aldo Cortesi.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 010844e440..b3a5ae2073 100644
--- a/configure.in
+++ b/configure.in
@@ -177,7 +177,7 @@ case $ac_sys_system/$ac_sys_release in
# On OpenBSD, select(2) is not available if _XOPEN_SOURCE is defined,
# even though select is a POSIX function. Reported by J. Ribbens.
# Reconfirmed for OpenBSD 3.3 by Zachary Hamm, for 3.4 by Jason Ish.
- OpenBSD/2.* | OpenBSD/3.@<:@012345678@:>@)
+ OpenBSD/2.* | OpenBSD/3.@<:@0123456789@:>@)
define_xopen_source=no;;
# On Solaris 2.6, sys/wait.h is inconsistent in the usage
# of union __?sigval. Reported by Stuart Bishop.
@@ -1474,13 +1474,27 @@ then
;;
Linux*|GNU*) LDSHARED='$(CC) -shared';;
BSD/OS*/4*) LDSHARED="gcc -shared";;
- OpenBSD*|FreeBSD*)
+ FreeBSD*)
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
then
LDSHARED="$CC -shared ${LDFLAGS}"
else
LDSHARED="ld -Bshareable ${LDFLAGS}"
fi;;
+ OpenBSD*)
+ if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
+ then
+ LDSHARED='$(CC) -shared $(CCSHARED) ${LDFLAGS}'
+ else
+ case `uname -r` in
+ [[01]].* | 2.[[0-7]] | 2.[[0-7]].*)
+ LDSHARED="ld -Bshareable ${LDFLAGS}"
+ ;;
+ *)
+ LDSHARED='$(CC) -shared $(CCSHARED) ${LDFLAGS}'
+ ;;
+ esac
+ fi;;
NetBSD*|DragonFly*) LDSHARED="cc -shared ${LDFLAGS}";;
OpenUNIX*|UnixWare*)
if test "$GCC" = "yes"