summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-04-08 08:13:31 +0000
committerRonald Oussoren <ronaldoussoren@mac.com>2010-04-08 08:13:31 +0000
commit9ad6a51c791617de1d98c9dbb6150ffb55ee3489 (patch)
tree6f4b7231251f429b0eaace9bc98e1b6f323655d2 /configure.in
parent23f6a560e1ba64a7168c91916d5bc926260bf41f (diff)
downloadcpython-9ad6a51c791617de1d98c9dbb6150ffb55ee3489.tar.gz
This check-in fixes two problems:
1) A non-critical off-by-one error in pythonw 2) A problem in the configure script that caused builds with '--enable-framework --enable-universalsdk=/' to fail on OSX 10.6.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 1 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index bdc5b6c24f..68e6d5af95 100644
--- a/configure.in
+++ b/configure.in
@@ -1024,36 +1024,7 @@ yes)
if test "$UNIVERSAL_ARCHS" = "32-bit" ; then
UNIVERSAL_ARCH_FLAGS="-arch ppc -arch i386"
ARCH_RUN_32BIT=""
- LIPO_32BIT_FLAGS="-extract ppc7400 -extract i386"
-
-
- # You have to use different flags on various versions of
- # OSX to extract PPC code from an universal binary, basically
- # '-arch ppc' on OSX 10.4 and '-arch ppc7400' on anything
- # newer.
- # Because '-arch pp7400' works on OSX 10.5 or higher this
- # test is only present in the '32-bit' branch, all other
- # branches require OSX 10.5 to compile.
-
- AC_MSG_CHECKING(lipo flag for extracting ppc code)
- FN="test.$$"
- cat >${FN}.c <<-EOF
- int main() { return 0; }
-EOF
- ${CC} ${CFLAGS} -arch ppc -arch i386 -o ${FN} ${FN}.c -isysroot ${UNIVERSALSDK}
- if test $? != 0 ; then
- rm ${FN} ${FN}.c
- AC_MSG_RESULT([failed, assumee -extract ppc7400])
- else
- lipo -extract -output "${FN}.out" -arch ppc7400 "${FN}" 2>/dev/null
- if test $? != 0 ; then
- LIPO_32BIT_FLAGS="-extract ppc -extract i386"
- AC_MSG_RESULT("'-extract ppc'")
- else
- AC_MSG_RESULT("'-extract ppc7400'")
- fi
- rm -f ${FN} ${FN}.c ${FN}.out
- fi
+ LIPO_32BIT_FLAGS=""
elif test "$UNIVERSAL_ARCHS" = "64-bit" ; then
UNIVERSAL_ARCH_FLAGS="-arch ppc64 -arch x86_64"