summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-02-25 11:09:02 +0000
committerGeorg Brandl <georg@python.org>2011-02-25 11:09:02 +0000
commit43e17b930d958b4fa2774342d98502d20c2f1245 (patch)
tree0ba347c5c4bb7ad55a28d6167f62a9cc63f7d306 /configure.in
parent711bac0a6b54a2f874a20d7a8388d58936529cb1 (diff)
downloadcpython-43e17b930d958b4fa2774342d98502d20c2f1245.tar.gz
Merged revisions 88430,88438,88440 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r88430 | georg.brandl | 2011-02-15 20:48:59 +0100 (Di, 15 Feb 2011) | 1 line #730467: Another small AIX fix. ........ r88438 | georg.brandl | 2011-02-19 09:44:47 +0100 (Sa, 19 Feb 2011) | 1 line #10709: add back an updated AIX-NOTES (as README.AIX). ........ r88440 | georg.brandl | 2011-02-19 09:58:23 +0100 (Sa, 19 Feb 2011) | 1 line #11184: Fix large file support on AIX. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ed2f613c63..d0821916ac 100644
--- a/configure.in
+++ b/configure.in
@@ -1437,6 +1437,12 @@ fi
if test "$use_lfs" = "yes"; then
# Two defines needed to enable largefile support on various platforms
# These may affect some typedefs
+case $ac_sys_system/$ac_sys_release in
+AIX*)
+ AC_DEFINE(_LARGE_FILES, 1,
+ [This must be defined on AIX systems to enable large file support.])
+ ;;
+esac
AC_DEFINE(_LARGEFILE_SOURCE, 1,
[This must be defined on some systems to enable large file support.])
AC_DEFINE(_FILE_OFFSET_BITS, 64,
@@ -2042,7 +2048,7 @@ AC_CHECK_LIB(intl, textdomain,
case "$ac_sys_system" in
AIX*) AC_MSG_CHECKING(for genuine AIX C++ extensions support)
AC_LINK_IFELSE([
- AC_LANG_PROGRAM([[#include "/usr/lpp/xlC/include/load.h"]],
+ AC_LANG_PROGRAM([[#include <load.h>]],
[[loadAndInit("", 0, "")]])
],[
AC_DEFINE(AIX_GENUINE_CPLUSPLUS, 1,