summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-08-21 00:08:11 +0000
committerGuido van Rossum <guido@python.org>1997-08-21 00:08:11 +0000
commit438965831221b44fd5340b16236dc9a570cb1e6c (patch)
treeb3d5bd1050c124db4e3886b6f13e5794cd19fa78 /configure.in
parentd42f8a473f3d60cd30897ea276be1ff058d53e94 (diff)
downloadcpython-438965831221b44fd5340b16236dc9a570cb1e6c.tar.gz
Richard Jones: I think we can be confident in using 'CC="-Aa
-D_HPUX_SOURCE"' on HP 9.x and 10.x platforms.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 10545dcfc6..5e6e8765a1 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,13 @@ fi
AC_PROG_CC
+case $ac_sys_system in
+hp*|HP*)
+ case $CC in
+ cc|*/cc) CC="$CC -Aa -D_HPUX_SOURCE";;
+ esac;;
+esac
+
# LINKCC is the command that links the python executable -- default is $(CC).
# This is altered for AIX in order to build the export list before linking.
AC_SUBST(LINKCC)