summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2007-01-21 09:33:07 +0000
committerMartin v. Löwis <martin@v.loewis.de>2007-01-21 09:33:07 +0000
commit42884079ace5139df80cad2980463f46dd15be1a (patch)
tree0bb16d34bb3970e44b5ed9b46c62e9a0a667c288 /configure.in
parent2dbea63aa697da132397847f41ae7eb6cd18a3e1 (diff)
downloadcpython-42884079ace5139df80cad2980463f46dd15be1a.tar.gz
Patch #1610575: Add support for _Bool to struct.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1259ccfebc..1a11ec2ca2 100644
--- a/configure.in
+++ b/configure.in
@@ -1218,6 +1218,17 @@ if test "$have_long_long" = yes ; then
AC_CHECK_SIZEOF(long long, 8)
fi
+AC_MSG_CHECKING(for _Bool support)
+have_c99_bool=no
+AC_TRY_COMPILE([], [_Bool x; x = (_Bool)0;], [
+ AC_DEFINE(HAVE_C99_BOOL, 1, [Define this if you have the type _Bool.])
+ have_c99_bool=yes
+])
+AC_MSG_RESULT($have_c99_bool)
+if test "$have_c99_bool" = yes ; then
+AC_CHECK_SIZEOF(_Bool, 1)
+fi
+
AC_CHECK_TYPES(uintptr_t,
[AC_CHECK_SIZEOF(uintptr_t, 4)],
[], [#ifdef HAVE_STDINT_H