summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2010-05-08 10:14:46 +0000
committerMatthias Klose <doko@ubuntu.com>2010-05-08 10:14:46 +0000
commit0f870cca5f172546cb35062a4d505761a319f281 (patch)
tree7e1092ef584e2c3242987cde387e5de45a70373b /configure.in
parent65eed22e812da20d98071ab8187228dbbdb3cfa8 (diff)
downloadcpython-0f870cca5f172546cb35062a4d505761a319f281.tar.gz
- configure.in: Replace AC_HELP_STRING with AS_HELP_STRING
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in64
1 files changed, 32 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index 1d6cbc4a92..a8448ecb80 100644
--- a/configure.in
+++ b/configure.in
@@ -87,7 +87,7 @@ CONFIG_ARGS="$ac_configure_args"
AC_MSG_CHECKING([for --enable-universalsdk])
AC_ARG_ENABLE(universalsdk,
- AC_HELP_STRING([--enable-universalsdk@<:@=SDKDIR@:>@], [Build against Mac OS X 10.4u SDK (ppc/i386)]),
+ AS_HELP_STRING([--enable-universalsdk@<:@=SDKDIR@:>@], [Build against Mac OS X 10.4u SDK (ppc/i386)]),
[
case $enableval in
yes)
@@ -130,7 +130,7 @@ UNIVERSAL_ARCHS="32-bit"
AC_SUBST(LIPO_32BIT_FLAGS)
AC_MSG_CHECKING(for --with-universal-archs)
AC_ARG_WITH(universal-archs,
- AC_HELP_STRING([--with-universal-archs=ARCH], [select architectures for universal build ("32-bit", "64-bit", "3-way", "intel" or "all")]),
+ AS_HELP_STRING([--with-universal-archs=ARCH], [select architectures for universal build ("32-bit", "64-bit", "3-way", "intel" or "all")]),
[
AC_MSG_RESULT($withval)
UNIVERSAL_ARCHS="$withval"
@@ -147,7 +147,7 @@ AC_ARG_WITH(universal-archs,
AC_ARG_WITH(framework-name,
- AC_HELP_STRING([--with-framework-name=FRAMEWORK],
+ AS_HELP_STRING([--with-framework-name=FRAMEWORK],
[specify an alternate name of the framework built with --enable-framework]),
[
if test "${enable_framework}"; then
@@ -165,7 +165,7 @@ AC_ARG_WITH(framework-name,
])
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
AC_ARG_ENABLE(framework,
- AC_HELP_STRING([--enable-framework@<:@=INSTALLDIR@:>@], [Build (MacOSX|Darwin) framework]),
+ AS_HELP_STRING([--enable-framework@<:@=INSTALLDIR@:>@], [Build (MacOSX|Darwin) framework]),
[
case $enableval in
yes)
@@ -278,8 +278,8 @@ AC_SUBST(FRAMEWORKUNIXTOOLSPREFIX)
AC_SUBST(FRAMEWORKINSTALLAPPSPREFIX)
##AC_ARG_WITH(dyld,
-## AC_HELP_STRING(--with-dyld,
-## Use (OpenStep|Rhapsody) dynamic linker))
+## AS_HELP_STRING([--with-dyld],
+## [Use (OpenStep|Rhapsody) dynamic linker]))
##
# Set name for machine-dependent library files
AC_SUBST(MACHDEP)
@@ -485,7 +485,7 @@ AC_MSG_RESULT($ac_sys_machine)
# on that fiddles with OPT and BASECFLAGS?
AC_MSG_CHECKING(for --without-gcc)
AC_ARG_WITH(gcc,
- AC_HELP_STRING(--without-gcc,never use gcc),
+ AS_HELP_STRING([--without-gcc], [never use gcc]),
[
case $withval in
no) CC=${CC:-cc}
@@ -543,7 +543,7 @@ AC_SUBST(CXX)
AC_SUBST(MAINCC)
AC_MSG_CHECKING(for --with-cxx-main=<compiler>)
AC_ARG_WITH(cxx_main,
- AC_HELP_STRING([--with-cxx-main=<compiler>],
+ AS_HELP_STRING([--with-cxx-main=<compiler>],
[compile main() and link python executable with C++ compiler]),
[
@@ -608,7 +608,7 @@ esac
AC_EXEEXT
AC_MSG_CHECKING(for --with-suffix)
AC_ARG_WITH(suffix,
- AC_HELP_STRING(--with-suffix=.exe, set executable suffix),
+ AS_HELP_STRING([--with-suffix=.exe], [set executable suffix]),
[
case $withval in
no) EXEEXT=;;
@@ -736,7 +736,7 @@ AC_MSG_RESULT($GNULD)
AC_MSG_CHECKING(for --enable-shared)
AC_ARG_ENABLE(shared,
- AC_HELP_STRING(--enable-shared, disable/enable building shared python library))
+ AS_HELP_STRING([--enable-shared], [disable/enable building shared python library]))
if test -z "$enable_shared"
then
@@ -751,7 +751,7 @@ AC_MSG_RESULT($enable_shared)
AC_MSG_CHECKING(for --enable-profiling)
AC_ARG_ENABLE(profiling,
- AC_HELP_STRING(--enable-profiling, enable C-level code profiling),
+ AS_HELP_STRING([--enable-profiling], [enable C-level code profiling]),
[ac_save_cc="$CC"
CC="$CC -pg"
AC_TRY_RUN([int main() { return 0; }],
@@ -897,7 +897,7 @@ fi
# Check for --with-pydebug
AC_MSG_CHECKING(for --with-pydebug)
AC_ARG_WITH(pydebug,
- AC_HELP_STRING(--with-pydebug, build with Py_DEBUG defined),
+ AS_HELP_STRING([--with-pydebug], [build with Py_DEBUG defined]),
[
if test "$withval" != no
then
@@ -1601,7 +1601,7 @@ CC="$ac_save_cc"
AC_MSG_CHECKING(for --enable-toolbox-glue)
AC_ARG_ENABLE(toolbox-glue,
- AC_HELP_STRING([--enable-toolbox-glue], [disable/enable MacOSX glue code for extensions]))
+ AS_HELP_STRING([--enable-toolbox-glue], [disable/enable MacOSX glue code for extensions]))
if test -z "$enable_toolbox_glue"
then
@@ -2090,7 +2090,7 @@ esac
AC_MSG_CHECKING(for --with-libs)
AC_ARG_WITH(libs,
- AC_HELP_STRING([--with-libs='lib1 ...'], [link against additional libs]),
+ AS_HELP_STRING([--with-libs='lib1 ...'], [link against additional libs]),
[
AC_MSG_RESULT($withval)
LIBS="$withval $LIBS"
@@ -2102,14 +2102,14 @@ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
- AC_HELP_STRING([--with-system-expat], [build pyexpat module using an installed expat library]))
+ AS_HELP_STRING([--with-system-expat], [build pyexpat module using an installed expat library]))
AC_MSG_RESULT($with_system_expat)
# Check for use of the system libffi library
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
- AC_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]))
+ AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]))
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
@@ -2123,7 +2123,7 @@ AC_MSG_RESULT($with_system_ffi)
# Check for --with-dbmliborder
AC_MSG_CHECKING(for --with-dbmliborder)
AC_ARG_WITH(dbmliborder,
- AC_HELP_STRING([--with-dbmliborder=db1:db2:...], [order to check db backends for dbm. Valid value is a colon separated string with the backend names `ndbm', `gdbm' and `bdb'.]),
+ AS_HELP_STRING([--with-dbmliborder=db1:db2:...], [order to check db backends for dbm. Valid value is a colon separated string with the backend names `ndbm', `gdbm' and `bdb'.]),
[
if test x$with_dbmliborder = xyes
then
@@ -2143,7 +2143,7 @@ AC_SUBST(USE_SIGNAL_MODULE)
AC_SUBST(SIGNAL_OBJS)
AC_MSG_CHECKING(for --with-signal-module)
AC_ARG_WITH(signal-module,
- AC_HELP_STRING([--with-signal-module], [disable/enable signal module]))
+ AS_HELP_STRING([--with-signal-module], [disable/enable signal module]))
if test -z "$with_signal_module"
then with_signal_module="yes"
@@ -2165,7 +2165,7 @@ USE_THREAD_MODULE=""
AC_MSG_CHECKING(for --with-dec-threads)
AC_SUBST(LDLAST)
AC_ARG_WITH(dec-threads,
- AC_HELP_STRING([--with-dec-threads], [use DEC Alpha/OSF1 thread-safe libraries]),
+ AS_HELP_STRING([--with-dec-threads], [use DEC Alpha/OSF1 thread-safe libraries]),
[
AC_MSG_RESULT($withval)
LDLAST=-threads
@@ -2185,12 +2185,12 @@ AH_TEMPLATE(WITH_THREAD,
AC_MSG_CHECKING(for --with-threads)
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
AC_ARG_WITH(threads,
- AC_HELP_STRING([--with(out)-threads@<:@=DIRECTORY@:>@], [disable/enable thread support]))
+ AS_HELP_STRING([--with(out)-threads@<:@=DIRECTORY@:>@], [disable/enable thread support]))
# --with-thread is deprecated, but check for it anyway
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
AC_ARG_WITH(thread,
- AC_HELP_STRING([--with(out)-thread@<:@=DIRECTORY@:>@], [deprecated; use --with(out)-threads]),
+ AS_HELP_STRING([--with(out)-thread@<:@=DIRECTORY@:>@], [deprecated; use --with(out)-threads]),
[with_threads=$with_thread])
if test -z "$with_threads"
@@ -2271,7 +2271,7 @@ yes
THREADOBJ="Python/thread.o"],[
AC_MSG_CHECKING(for --with-pth)
AC_ARG_WITH([pth],
- AC_HELP_STRING([--with-pth], [use GNU pth threading libraries]),
+ AS_HELP_STRING([--with-pth], [use GNU pth threading libraries]),
[AC_MSG_RESULT($withval)
AC_DEFINE([WITH_THREAD])
AC_DEFINE([HAVE_PTH], 1,
@@ -2576,7 +2576,7 @@ AC_TRY_COMPILE([#include <Carbon/Carbon.h>], FSIORefNum fRef = 0,
# Check for --with-doc-strings
AC_MSG_CHECKING(for --with-doc-strings)
AC_ARG_WITH(doc-strings,
- AC_HELP_STRING([--with(out)-doc-strings], [disable/enable documentation strings]))
+ AS_HELP_STRING([--with(out)-doc-strings], [disable/enable documentation strings]))
if test -z "$with_doc_strings"
then with_doc_strings="yes"
@@ -2591,7 +2591,7 @@ AC_MSG_RESULT($with_doc_strings)
# Check for Python-specific malloc support
AC_MSG_CHECKING(for --with-tsc)
AC_ARG_WITH(tsc,
- AC_HELP_STRING([--with(out)-tsc],[enable/disable timestamp counter profile]),[
+ AS_HELP_STRING([--with(out)-tsc],[enable/disable timestamp counter profile]),[
if test "$withval" != no
then
AC_DEFINE(WITH_TSC, 1,
@@ -2604,7 +2604,7 @@ fi],
# Check for Python-specific malloc support
AC_MSG_CHECKING(for --with-pymalloc)
AC_ARG_WITH(pymalloc,
- AC_HELP_STRING([--with(out)-pymalloc], [disable/enable specialized mallocs]))
+ AS_HELP_STRING([--with(out)-pymalloc], [disable/enable specialized mallocs]))
if test -z "$with_pymalloc"
then with_pymalloc="yes"
@@ -2619,7 +2619,7 @@ AC_MSG_RESULT($with_pymalloc)
# Check for Valgrind support
AC_MSG_CHECKING([for --with-valgrind])
AC_ARG_WITH([valgrind],
- AC_HELP_STRING([--with-valgrind], [Enable Valgrind support]),,
+ AS_HELP_STRING([--with-valgrind], [Enable Valgrind support]),,
with_valgrind=no)
AC_MSG_RESULT([$with_valgrind])
if test "$with_valgrind" != no; then
@@ -2632,7 +2632,7 @@ fi
# Check for --with-wctype-functions
AC_MSG_CHECKING(for --with-wctype-functions)
AC_ARG_WITH(wctype-functions,
- AC_HELP_STRING([--with-wctype-functions], [use wctype.h functions]),
+ AS_HELP_STRING([--with-wctype-functions], [use wctype.h functions]),
[
if test "$withval" != no
then
@@ -3350,7 +3350,7 @@ AC_CHECK_FUNC(__fpu_control,
# Check for --with-fpectl
AC_MSG_CHECKING(for --with-fpectl)
AC_ARG_WITH(fpectl,
- AC_HELP_STRING([--with-fpectl], [enable SIGFPE catching]),
+ AS_HELP_STRING([--with-fpectl], [enable SIGFPE catching]),
[
if test "$withval" != no
then
@@ -3370,7 +3370,7 @@ BeOS) ;;
esac
AC_MSG_CHECKING(for --with-libm=STRING)
AC_ARG_WITH(libm,
- AC_HELP_STRING([--with-libm=STRING], [math library]),
+ AS_HELP_STRING([--with-libm=STRING], [math library]),
[
if test "$withval" = no
then LIBM=
@@ -3386,7 +3386,7 @@ fi],
AC_SUBST(LIBC)
AC_MSG_CHECKING(for --with-libc=STRING)
AC_ARG_WITH(libc,
- AC_HELP_STRING([--with-libc=STRING], [C library]),
+ AS_HELP_STRING([--with-libc=STRING], [C library]),
[
if test "$withval" = no
then LIBC=
@@ -3651,7 +3651,7 @@ fi
# determine what size digit to use for Python's longs
AC_MSG_CHECKING([digit size for Python's longs])
AC_ARG_ENABLE(big-digits,
-AC_HELP_STRING([--enable-big-digits@<:@=BITS@:>@],[use big digits for Python longs [[BITS=30]]]),
+AS_HELP_STRING([--enable-big-digits@<:@=BITS@:>@],[use big digits for Python longs [[BITS=30]]]),
[case $enable_big_digits in
yes)
enable_big_digits=30 ;;
@@ -3717,7 +3717,7 @@ fi
AC_MSG_CHECKING(what type to use for unicode)
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
AC_ARG_ENABLE(unicode,
- AC_HELP_STRING([--enable-unicode@<:@=ucs@<:@24@:>@@:>@], [Enable Unicode strings (default is yes)]),
+ AS_HELP_STRING([--enable-unicode@<:@=ucs@<:@24@:>@@:>@], [Enable Unicode strings (default is yes)]),
[],
[enable_unicode=yes])