summaryrefslogtreecommitdiff
path: root/lib/scudo/standalone/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Kortchinsky <kostyak@google.com>2019-04-30 14:56:18 +0000
committerKostya Kortchinsky <kostyak@google.com>2019-04-30 14:56:18 +0000
commit8d158e4bfb63c4792b7135d0625fcc4592dcac7b (patch)
tree04d46547b270323f9b84484cb9038e0e8105fee9 /lib/scudo/standalone/tests/CMakeLists.txt
parentd201961150fe163d41c4e0bf9c296ed69780d3b2 (diff)
downloadcompiler-rt-8d158e4bfb63c4792b7135d0625fcc4592dcac7b.tar.gz
[scudo][standalone] Add the memory reclaiming mechanism
Summary: This CL implements the memory reclaiming function `releaseFreeMemoryToOS` and its associated classes. Most of this code was originally written by Aleksey for the Primary64 in sanitizer_common, and I made some changes to be able to implement 32-bit reclaiming as well. The code has be restructured a bit to accomodate for freelist of batches instead of the freearray used in the current sanitizer_common code. Reviewers: eugenis, vitalybuka, morehouse, hctim Reviewed By: vitalybuka Subscribers: srhines, mgorny, delcypher, #sanitizers, llvm-commits Tags: #llvm, #sanitizers Differential Revision: https://reviews.llvm.org/D61214 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@359567 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/scudo/standalone/tests/CMakeLists.txt')
-rw-r--r--lib/scudo/standalone/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/scudo/standalone/tests/CMakeLists.txt b/lib/scudo/standalone/tests/CMakeLists.txt
index 5fcf67903..75c67263b 100644
--- a/lib/scudo/standalone/tests/CMakeLists.txt
+++ b/lib/scudo/standalone/tests/CMakeLists.txt
@@ -56,6 +56,7 @@ set(SCUDO_UNIT_TEST_SOURCES
list_test.cc
map_test.cc
mutex_test.cc
+ release_test.cc
report_test.cc
secondary_test.cc
size_class_map_test.cc