summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDean Michael Berris <dberris@google.com>2016-07-21 08:53:31 +0000
committerDean Michael Berris <dberris@google.com>2016-07-21 08:53:31 +0000
commit1690c43ede4c1f356fcace36ddc9e7aff157fdd2 (patch)
tree1b0a1ed0a616ecf29a779656a82242cfd4aa85ed /CMakeLists.txt
parent1158112aee03cd0a0d917dfda52fab5ba416339f (diff)
downloadcompiler-rt-1690c43ede4c1f356fcace36ddc9e7aff157fdd2.tar.gz
Default XRay building to OFF to let build bots that do not support building sanitizers to disable explicitly too
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276255 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f61d1507..1699460e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,9 @@ option(COMPILER_RT_BUILD_BUILTINS "Build builtins" ON)
mark_as_advanced(COMPILER_RT_BUILD_BUILTINS)
option(COMPILER_RT_BUILD_SANITIZERS "Build sanitizers" ON)
mark_as_advanced(COMPILER_RT_BUILD_SANITIZERS)
-option(COMPILER_RT_BUILD_XRAY "Build xray" ON)
+
+# TODO: Flip this to default ON when build bots recognize this new option.
+option(COMPILER_RT_BUILD_XRAY "Build xray" OFF)
mark_as_advanced(COMPILER_RT_BUILD_XRAY)
if (COMPILER_RT_STANDALONE_BUILD)