summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build14
1 files changed, 8 insertions, 6 deletions
diff --git a/data/meson.build b/data/meson.build
index e9bf87b..00ac6ec 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -6,12 +6,6 @@ subdir('ref')
subdir('tests')
subdir('ti1')
-if get_option('systemd')
- install_data('colord.conf',
- install_dir: systemd.get_pkgconfig_variable('tmpfilesdir')
- )
-endif
-
if get_option('bash_completion')
install_data('colormgr',
install_dir: bash_completion.get_pkgconfig_variable('completionsdir')
@@ -31,6 +25,14 @@ if get_option('systemd')
install: true,
install_dir: systemd.get_pkgconfig_variable('systemdsystemunitdir'),
)
+
+ configure_file(
+ input : 'colord.conf.in',
+ output : 'colord.conf',
+ configuration : con2,
+ install: true,
+ install_dir: systemd.get_pkgconfig_variable('tmpfilesdir')
+ )
endif
# replace @servicedir@ and @daemon_user@