summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenedikt Morbach <benedikt.morbach@googlemail.com>2012-01-12 16:22:50 +0100
committerRichard Hughes <richard@hughsie.com>2012-01-17 11:06:20 +0000
commitb144a92d611ca0a7824d9c85eb1da43e01a7c8b5 (patch)
tree4d9f1106202f7b40690c23f786118922e104aca1 /configure.ac
parentfe07880032d6c74d93495e57347709a856e7fa9d (diff)
downloadcolord-b144a92d611ca0a7824d9c85eb1da43e01a7c8b5.tar.gz
Install a systemd service file if systemd is used
This makes dbus defer starting colord to systemd instead of doing it itself and thus puts the daemon under proper systemd supervision. Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ad111e0..1796f4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,17 @@ if test x$enable_polkit = xyes; then
fi
dnl ---------------------------------------------------------------------------
+dnl - Select whether and where to install systemd system service files
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [],
+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+
+dnl ---------------------------------------------------------------------------
dnl - Build DBus examples
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(examples, AS_HELP_STRING([--enable-examples],[enable DBus example code]),