summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-10-22 12:12:30 -0300
committerRichard Hughes <richard@hughsie.com>2021-10-22 16:39:52 +0100
commitce096b5fa63a1c99d123248d4679969c032f06f4 (patch)
tree3f6c654ff1fb5b1960e569fb840d704d92bfd577 /meson.build
parentfd05fb0a18b9719ae5652afe1aa22d71acce99f2 (diff)
downloadcolord-gtk-ce096b5fa63a1c99d123248d4679969c032f06f4.tar.gz
Add a GTK4 variant
This commits adds a GTK4 variant, libcolord-gtk4. An effort was made to keep the changes as separate and self-contained as possible. The new GTK4 code of the sample window and widget is introduced in separated files, reusing the cd-sample-{window,widget}.h headers. There was only one place in CdWindow that required split GTK3 / GTK4 paths, and fortunately it is a rather trivial one.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c282ee9..e947c84 100644
--- a/meson.build
+++ b/meson.build
@@ -102,6 +102,10 @@ if get_option('gtk2')
conf.set('HAVE_GTK2', '1')
endif
+if get_option('gtk4')
+ gtk4 = dependency('gtk4', version : '>= 4.4')
+endif
+
gnome = import('gnome')
i18n = import('i18n')