summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2013-05-17 16:14:50 +0100
committerRichard Hughes <richard@hughsie.com>2013-05-17 16:14:50 +0100
commite14d364bb38716758e9dfeebd7f453d7be311743 (patch)
treecc09751e246c3f0067186ceac63df38dcb1535f6 /configure.ac
parent54627d46d9e6498bb97d323afa5fbcc9161d6ee2 (diff)
downloadcolord-gtk-e14d364bb38716758e9dfeebd7f453d7be311743.tar.gz
Provide an optional Gtk2 version of libcolord-gtk
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index adcbecc..af75edf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,11 +124,21 @@ dnl ---------------------------------------------------------------------------
dnl - Check library dependencies
dnl ---------------------------------------------------------------------------
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.28.0 gobject-2.0 gthread-2.0 gio-2.0 >= 2.25.9 gio-unix-2.0 gmodule-2.0)
-PKG_CHECK_MODULES(GTK, gtk+-3.0)
+PKG_CHECK_MODULES(GTK3, gtk+-3.0)
PKG_CHECK_MODULES(COLORD, colord >= 0.1.27)
PKG_CHECK_MODULES(LCMS, lcms2 >= 2.2)
dnl ---------------------------------------------------------------------------
+dnl - Build Gtk+2 support
+dnl ---------------------------------------------------------------------------
+AC_ARG_ENABLE(gtk2, AS_HELP_STRING([--enable-gtk2],[build Gtk2 library]),
+ enable_gtk2=$enableval,enable_gtk2=no)
+if test x$enable_gtk2 != xno; then
+ PKG_CHECK_MODULES(GTK2, gtk+-2.0)
+fi
+AM_CONDITIONAL(HAVE_GTK2, [test "x$enable_gtk2" = "xyes"])
+
+dnl ---------------------------------------------------------------------------
dnl - Build VALA support
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(vala, AS_HELP_STRING([--enable-vala],[build vala bindings]),
@@ -162,6 +172,7 @@ po/Makefile.in
client/Makefile
libcolord-gtk/cd-version.h
libcolord-gtk/colord-gtk.pc
+libcolord-gtk/colord-gtk2.pc
libcolord-gtk/Makefile
])
AC_OUTPUT
@@ -178,4 +189,5 @@ echo "
cppflags: ${CPPFLAGS}
gobject-introspection: ${found_introspection}
Vala API generator: ${has_vapigen}
+ Additional Gtk+2 support: ${enable_gtk2}
"