summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorMartin Blanchard <tchaik@gmx.com>2019-05-30 13:55:45 +0200
committerRichard Hughes <richard@hughsie.com>2019-06-09 18:17:37 +0100
commit7f358c676ba0990421d6a038569c8b798353e52b (patch)
tree82a788799f3b586013248c50d66276788e310cc7 /client/Makefile.am
parenta87889cebedbf0b3d45a41e83287b0b0f8fae7b7 (diff)
downloadcolord-gtk-7f358c676ba0990421d6a038569c8b798353e52b.tar.gz
build: Port to the Meson build system
Introduce meson build scripts along autotools ones. Porting modules to the meson build system is a GNOME Goal, details here: https://wiki.gnome.org/Initiatives/GnomeGoals/MesonPorting https://github.com/hughsie/colord-gtk/issues/10
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am32
1 files changed, 0 insertions, 32 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
deleted file mode 100644
index f143dcb..0000000
--- a/client/Makefile.am
+++ /dev/null
@@ -1,32 +0,0 @@
-INCLUDES = \
- $(GLIB_CFLAGS) \
- $(GTK3_CFLAGS) \
- $(COLORD_CFLAGS) \
- -I$(top_srcdir) \
- -I$(top_srcdir)/libcolord-gtk \
- -DG_LOG_DOMAIN=\"Cd\" \
- -DCD_COMPILATION \
- -DVERSION="\"$(VERSION)\"" \
- -DLOCALEDIR=\""$(localedir)"\"
-
-COLORD_GTK_LIBS = \
- $(top_builddir)/libcolord-gtk/libcolord-gtk.la
-
-bin_PROGRAMS = \
- cd-convert
-
-cd_convert_SOURCES = \
- cd-convert.c
-
-cd_convert_LDADD = \
- $(LCMS_LIBS) \
- $(COLORD_LIBS) \
- $(COLORD_GTK_LIBS) \
- $(GTK3_LIBS) \
- $(GLIB_LIBS) \
- -lm
-
-cd_convert_CFLAGS = \
- $(WARNINGFLAGS_C)
-
--include $(top_srcdir)/git.mk